AEM/CQ5 AuthenticationSupport service missing

My computer crashed and on restart my local instance was not working property (blank pages). Looking at the error.log there was

org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

After a quick look at the felix console and having seen all the bundles up and running I went to reading backwards the error.log. I saw that during the start-up Lucene was failing to start and therefore the repository was not initialized correctly.

I managed to have my local instace back to work by having CQ fully regenerate my Lucene indexes.

See How to check and repair search index inconsistencies (Completely rebuild the index)

Advertisements

4 thoughts on “AEM/CQ5 AuthenticationSupport service missing

  1. Siva says:

    I am facing the same issue. Could you elaborate on how to fix it.

    I managed to have my local instace back to work by having CQ fully regenerate my Lucene indexes.?

    • Mrinal says:

      1. Stop your instance.
      2.go to > crx-quickstart\repository\index and delete index folder.
      3.Resart the instance (This will regenerate Lucene indexes fully)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s